Norskale / Citrix WEM Agent remains offline

9 Dec

At the moment I’m playing around with Norskale. The environment manager solution Citrix has purchased. It’s free in the platinum edition, and really cool. Ofcourse it immediately took me an evening stumbling upon something nobody wrote about. So there we go:

After installing Norskale, configuring the broker etc. etc. you’re finally ready to install the agent. The agent will never appear in Norskale.
In eventlog you will see:

Service appears to be Offline and no valid local cache found! and Agent Host detected as offline -> Exiting Local Cache Synchronization . You verify everything over and over.

– is the brokername FQDN OK, check
– is the broker reachable, check
– reboot, check
– reinstall, check

At that moment I was a little lost and posted the Citrix forum. I also contacted Norskale. They told me it had something to do with the connection to the broker, which I quadruplechecked.

Then it hit me…. Could it be that Norskale doesn’t talk IPv6?
And yes there it is. I changed the broker hostname to an IPv4 adress and suddenly the software came alive.

Norskale confirmed my suspicion. Ipv6 isn’t supported.

Debug log for indexing purposes:

————————————————————————————————

Citrix Workspace Environment Management Agent Service Debug Log

————————————————————————————————

9:07:19 PM Event -> VuemAgentServiceConfigurationHelper.DoCfgReport() : Registry Configuration Report:

Agent Broker Server:
if1.mydomain.local
Agent Broker Port: 8286
Agent Broker Sync Port: 8285
Agent Site: WIN10VDI
Agent Path: C:\Program Files (x86)\Norskale\Norskale Agent Host\
RDS Host: False
Use Non Persistent Compliant History: False

9:07:19 PM Exception -> ConfigurationDataSourcesHelper.CheckAgentBrokerServiceClient() : System.UriFormatException : Invalid URI: The hostname could not be parsed.
9:07:20 PM Event -> SensMonitoring.InternalRun() : SENS Events Subscription Started
9:07:20 PM Exception -> ConfigurationDataSourcesHelper.CheckBrokerSvcConnection() : Broker Svc Check -> Failed
9:07:20 PM Exception -> AgentServiceHelper.OpenDataConnection() : Service appears to be Offline and no valid local cache found!
9:07:20 PM Event -> SensMonitoring.InternalRun() : SENS Events Subscription Completed
9:07:20 PM Event -> MainServiceHost.StartAgentHostService() : Agent Host Service started
9:07:20 PM Event -> AgentServiceHelper.OpenLocalDatabaseConnection() : Opening configuration local database connection -> c:\agentcache\LocalAgentDatabase.sdf
9:07:20 PM Warning -> AgentLocalCacheSync.InternalRun() : Agent Host detected as offline -> Exiting Local Cache Synchronization
9:07:20 PM Event -> MainServiceHost.StartAgentProxyService() : Agent Proxy service started
9:07:20 PM Event -> MainServiceHost.StartAgentMessagingService() : Agent Messaging service started
9:07:20 PM Event -> MainServiceHost.StartCacheSyncInterfaceService() : Agent Cache Synchronization Interface service started
9:07:20 PM Event -> MainServiceHost.StartAgentWcfService() : Agent Command Processor service started
9:07:20 PM Event -> AgentHostService.() : Agent Host Service Initialization Completed.

Agent Service Version: 4.1.0.0
9:07:25 PM Event -> RegistryConfigurationMonitor.InternalRun() : Group Policy Watcher Started

Comments

  • Richard, is saying:

    I had the same problem, and after changing the FQDN in GPO setting to IP address of the Broker server, all started to work.

    Thanks for this solution

    Reply this message

Leave a Reply to Richard Cancel Reply